Back to overview
Downtime

Booking Confirmation Delays - Meeting Creation Issues

Oct 06 at 02:05pm WEST
Affected services
System Health

Resolved
Oct 06 at 02:15pm WEST

Booking Confirmation System Fully Operational

The issue affecting booking confirmations has been fully resolved.
All systems are now operating normally.

What Was Fixed:
We identified and corrected two technical issues in our booking
confirmation pipeline:

  1. A security configuration that was inadvertently blocking automated booking processes after successful payments
  2. A validation rule that was being applied incorrectly to already-paid bookings

Resolution:
✅ All booking confirmations are now processing immediately
✅ Calendar invitations are being generated correctly
✅ Confirmation emails are being sent promptly
✅ Payment processing was never affected - all transactions remained secure

Impact Period:
September 30 - October 6, 2025

Affected Customers:
If you made a booking during this period and did not receive your
confirmation email or calendar invite, please check your email (including
spam folder) within the next hour. We are retroactively processing all
affected bookings.

If you still haven't received your confirmation after 2 hours, please
contact our support team and we will assist you immediately.

What We're Doing:
We have implemented additional monitoring to prevent similar issues in
the future and are reviewing our webhook processing pipeline to ensure
reliability.

We sincerely apologize for any inconvenience this may have caused and
appreciate your patience while we resolved this issue.

All systems are now operating normally. Thank you for your understanding.

Created
Oct 06 at 02:05pm WEST

We are currently investigating an issue affecting booking confirmations for appointments made between September 30 and October 6, 2025.

Impact:
• Some customers may have completed payment but not received their booking confirmation emails
• Calendar invites may not have been generated for affected bookings
• All payments were processed successfully and are secure

Current Status:
We have identified the root cause as a configuration issue in our security layer that was inadvertently blocking automated meeting creation after successful payments. Our engineering team has implemented a fix and is currently testing the solution.

What We're Doing:
• Deploying the fix to production
• Retroactively creating calendar events for affected bookings
• Sending delayed confirmation emails to impacted customers

Next Steps:
We will update this status once testing is complete and all affected bookings have been processed. We expect full resolution within the next few hours.

We apologize for any inconvenience and appreciate your patience.